حل ارور Warning: Cannot modify header information – headers already sent by در PHP

خب سلام دوستان.

تو یکی از پروژه ها به ارور زیر برخوردم:

Warning: Cannot modify header information – headers already sent by (output started at /some/file.php:12) in /some/file.php on line 23

این ارور چندتا دلیل داره که مشکل من با روش زیر که بهتون میگم حل شد. شاید واسه شما با راه حل های دیگه که لینکشو میذارم حل شه ولی پیشنهاد میکنم این راه حل رو انجام بدید اگه جواب نداد برید بعدیا.

کدهای php رو تو بالاترین قسمت سایت قرار بدید؛ یعنی بالای :

<!DOCTYPE html>

اگه مشکل حل نشد ، برید لینک زیر و بقیه ی راه حل هارو حل کنید.

https://2ad.ir/WV95SNFv

حل مشکلUnable to locate package در کالی لینوکس

سلام همگی.

به یکی از چرت ترین مشکلات کالی میرسیم. هر نرم افزار یا پکیجی رو که میخواید نصب کنید با ارور Unable to locate package مواجه میشید. اینجا با دوتا خط بتون میگم چیکار کنید.

اگه با این تاپیک مشکلتون حل شد کامنت بذارید تا مام انرژی بگیریم از کامون

1- داخل ترمینال تایپ کنید:

sudo nano /etc/apt/sources.list

2- این دوتا مورد رو کپی کنید:

deb http://http.kali.org/kali kali-rolling main non-free contrib
deb   http://http.kali.org/kali   kali-rolling   main non-free contrib

3- حالا دکمه های ctrl + o رو همزمان فشار بدید. پیغامی مث این File Name to Write: etc…. میبینید. فقط Enter رو فشار بدید. یکم زمان میبره تا مخزن هارو دانلود کنه.

حالا محض اطمینان تایپ کنید: sudo apt-get update

و بعدش : sudo apt-get install checkinstall

کارتمومه! نظر یادتون نره 🙂